Help desk outage
Incident Report for Marketplace® Simulations
Resolved
The Support Side issue has been resolved since 1:51 pm EDT.
Posted Aug 08, 2018 - 14:09 EDT
Investigating
Our customers are currently unable to access our Support Site and are unable to open new tickets or manage their open tickets. If you need to contact Marketplace Simulation Support, please call us at +1 865 522 1946. Please continue to monitor this page for updates.
Posted Aug 08, 2018 - 13:01 EDT
This incident affected: Marketplace® Simulations Support Site.